Qualys Cloud Agent: Support for Legacy Operating Systems – Important Changes

Spencer Brown

As technology advances and security threats evolve, it’s imperative to ensure that our systems remain robust and capable of meeting modern security standards.

In light of ongoing enhancements and the integration of support for modern third-party packages within the Cloud Agent ecosystem, both Windows Qualys Cloud Agent 5.6 and Linux Qualys Cloud Agent 6.1 will mark the final builds for specific legacy operating systems. These changes are essential to address the increasing complexity of security requirements. Should businesses require continued support for these legacy operating systems, customers may continue utilizing Windows Qualys Cloud Agent 5.6 and Linux Qualys Cloud Agent 6.1.

Windows Qualys Cloud Agent 5.6

  • Windows XP
  • Windows Server 2003
  • Windows Server 2003 R2
  • Windows Vista
  • Windows Server 2008
  • Windows Server 2008 R2

Linux Qualys Cloud Agent 6.1

  • CentOS 5.x and prior
  • Red Hat Enterprise Linux 5.x and prior
  • SUSE Linux Enterprise Server (SLES) 11 and prior
  • Oracle Enterprise Linux (OEL) 5.x and prior

Auto-Upgrade of Qualys Agent on Legacy Operating Systems: What to Expect

Qualys has implemented a seamless transition process for those utilizing auto-upgrade of the Qualys Agent on the legacy operating systems mentioned above. Agents on these systems will automatically be excluded from auto-upgrading, ensuring interoperability and uninterrupted experience for your organization.

What Happens If You Try to Install or Manually Upgrade Using a Non-supported Windows Qualys Cloud Agent Version (5.7 or greater) on Legacy Operating Systems?

The install or upgrade will fail. An error message will be added later.

What Happens If You Try to Install or Manually Upgrade Using a Non-supported Linux Qualys Cloud Agent Version (6.2 or greater) on Legacy Operating Systems?

The install or upgrade will fail due to a dependency error with the following message:

error: Failed dependencies: rpmlib(FileDigests) <= 4.6.0-1 is needed by qualys -cloud-agent-6.2.1-9.x86_64 rpmlib(PayloadIsXz) <= 5.2-1 is needed by qualys-cloud-agent-6.2.1-9.x86_64

For those operating one of the operating systems above who wish to continue to receive the latest Qualys Agent, we recommend upgrading to the latest operating system version.

We appreciate your understanding and cooperation as we implement these crucial changes to further fortify your security posture. At Qualys, we remain dedicated to providing cutting-edge solutions that empower you to protect what matters most.

If you have any questions about the operating systems supported by the Qualys Cloud Agent, please connect with your TAM or contact support

Share your Comments

Comments

Your email address will not be published. Required fields are marked *